Loading blocked by failures with other queries

Hi,

Just dowloaded and installed sqlwatch :slight_smile:

It all seems to work database wise but I cannot get the PowerBi Dashboard to load data from my sql server. Not sure if it matters but I used dbatools and Install-DbaSqlWatch to install.

My problem is the PowerBI Dashboard.Once I change the parameters and apply changes I see the status go from Evaluating to Loading blocked by failures with other queries.

What I have tried so far.

  1. Always ignore Privacy Level Setting
  2. Disable parallel loading of tables
  3. Tried different instances

I do have named instances not sure if that matters?

Please help :mask:

What is the actual error that PBI is reporting?

As the header says in the topic, none of the tables load and they all report the same.

When i preview the data it all loads ok but not when I try to save the power bi file.

Is a single query failed, the rest will also fail reporting they are blocked due to dependency. The one that actually failed will Resort why. You just need to scroll to the actual errro.

Hi, had a similar issue after installation. Scrolled down and for me it couldn’t run a particular query:
“File Statistics Sankey Database to File” if I remember correctly. Had to go into Power Query Editor and locate that table. It seemed that in the “Applied Steps” at position 3-4 somewhere it tried to delete a column that didnt excist. Think it was called “Database_Table” or something. After removing that step it completed successfully.

applied_steps

Hi again, just confirmed with original PBIX file and the column name was “database_name”

database_name

Additional: My version of the file is “SQLWATCH Dashboard 20200820”

Thanks a bunch for taking the time Jonas!

Will try the solution once I get the chance and report back here.

Power BI is now loading, thank you for the support Marcin and Jonas.

1 Like

Great to hear that it helped! :slight_smile:

Well it didn’t quite work as there are some other issues in the PBI dashboard that I got from here:

However, I did get it to work with the PBI dashboard from here:

So far I only changed the Oldest LOG backup (minutes) from last_backup_finish_date to backup_finish_date as it gave me an error, I’m running sql server 2019.

You should only be using a dashboard from the official release i.e. 2.6 or 2.5, not the one from the branch as this is the work in progress next gen release

1 Like

Got it, thanks for all your effort you put into this tool.
Really appretiate it :raised_hands:

This is so important to remember. Caused me a lot of issues.