EnvironmentToProcess not recognized in the importer?

Apologies in advance if this question is already covered elsewhere.
After I set an environment value of “TEST” on some entries in sqlwatch_config_sql_instance, and then set EnvironmentToProcess value to TEST in the config file, it seems that the importer is not adding the environment to the processing query. A Profiler trace shows:

select RemoteSqlInstance = sql_instance
, Hostname=isnull(hostname,sql_instance) + isnull(’,’+convert(varchar(10),[sql_port]),’’)
, SqlSecret=isnull([sql_secret],’’)
, SqlUser=isnull([sql_user],’’)
, SqlWatchDatabase = [sqlwatch_database_name]
from [dbo].[sqlwatch_config_sql_instance]
where repo_collector_is_active = 1

Am I missing something about the environment usage? My importer version is 1.2.8308.36871.

Hi, this is a known bug. The app doesn’t respect the environment setting. Apologies for that.

Ok, thanks. I’ll see about adding a Config.EnvironmentToProcess = “ALL” check to GetRemoteInstancesAsync().